Help - Search - Members - Calendar
Full Version: A New Donation from tech2000
ElantraClub - Elantra Owner and Enthusiast Archive > Community > The Community Center > Club Donations


View New Posts
elantragt
A big thank you goes to tech2000 for their donation of 15.00 USD.
RPW00Mirage
thank you!
elantragt
I was so impressed with this donation I made tech2000 a EC VIP. smile.gif
bhorste
signs-woo.gif
tech2000
you're very welcome fellas. awesome sight here. how long has it been up? i just bought a gently used 03 GT hatch with 192k on it. bought second hand at 28k. really clean car. never modded, not even the stereo. she will need a few things i would imagine. there are some issues but she purrs like a kitten, and doesnt leak oil or any fluid for that matter. the last thing they had replaced before making the decision to jump into a new Azera was the MAP sensor. they bought the single bolt sensor but still the symptom of stalling after coming to a stop persists. she fires right up though and holds idle fine. maybe the Idle speed actuator? bad alternator?? doesnt like the single bolt MAP sensor??? idk, but the car will not be on the road until the end of January. so i have time to scour EC for a solution.

Ive been a proud owner of a 2000 Tiburon for 14 years so Im familiar with the beta engine... this beta2 is new to me. but alas the Tib is dire need of a rest. shes been a daily driver for the life of the car, but she has developed a drinking problem... she drinks like a quart every 500 miles... no smoke from the tail pipe, but a lot around the valve cover... not sure if shes burning it as much as shes leaking it out the top of the engine but i just have this feeling that one week, im going to forget to check the oil, and she gonna run dry on me. ive been on the forums as loneshark2000, but with a new ride, comes a new call sign. i hope you can make the budget and keep this site up!
bhorste
QUOTE (tech2000 @ Dec 31 2014, 03:38 PM) *
you're very welcome fellas. awesome sight here. how long has it been up? i just bought a gently used 03 GT hatch with 192k on it. bought second hand at 28k. really clean car. never modded, not even the stereo. she will need a few things i would imagine. there are some issues but she purrs like a kitten, and doesnt leak oil or any fluid for that matter. the last thing they had replaced before making the decision to jump into a new Azera was the MAP sensor. they bought the single bolt sensor but still the symptom of stalling after coming to a stop persists. she fires right up though and holds idle fine. maybe the Idle speed actuator? bad alternator?? doesnt like the single bolt MAP sensor??? idk, but the car will not be on the road until the end of January. so i have time to scour EC for a solution.

Ive been a proud owner of a 2000 Tiburon for 14 years so Im familiar with the beta engine... this beta2 is new to me. but alas the Tib is dire need of a rest. shes been a daily driver for the life of the car, but she has developed a drinking problem... she drinks like a quart every 500 miles... no smoke from the tail pipe, but a lot around the valve cover... not sure if shes burning it as much as shes leaking it out the top of the engine but i just have this feeling that one week, im going to forget to check the oil, and she gonna run dry on me. ive been on the forums as loneshark2000, but with a new ride, comes a new call sign. i hope you can make the budget and keep this site up!


Welcome to the Club! As for the oil leak on your Tibby, doing a valve cover gasket replacement is really pretty easy, and they're cheap too. I don't blame you giving it a rest, but I'd look into swapping the VCG and see if that doesn't help with your consumption problem.
tech2000
yep. ive taken the VCG off once before..... errrr... 10 years and like 120k miles ago.. wow... good times.... to install the 1.8 intake cam. should be no prob. what kit do you recommend? one that has all the rubbers needed?
bhorste
QUOTE (tech2000 @ Jan 1 2015, 12:39 PM) *
yep. ive taken the VCG off once before..... errrr... 10 years and like 120k miles ago.. wow... good times.... to install the 1.8 intake cam. should be no prob. what kit do you recommend? one that has all the rubbers needed?


Yup. I think I bought a Fel-Pro when I did mine.
tech2000
thanks. will look into it.
Alex2013GT
Thanks for the donation and good luck with the car!

QUOTE (tech2000 @ Dec 31 2014, 03:38 PM) *
you're very welcome fellas. awesome sight here. how long has it been up?


As far as how long the site has been up. . . Well this version of the forum has been up just over 10 years. There was an EZ board forum for a couple years before that along with the main site that Mitch labored over for many, many hours. The main site is actually how I found this club when I had first purchased my '04 GT. I spent countless hours going through the pictures and details of all the various aftermarket parts for the car that were posted there at the main site along with the DIY projects.
tech2000
nicely done though. site has many bells and whistles. would be a shame to see it go.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.